WordPress 2.5 fue lanzado durante el fin de semana pasado y aunque es bastante estable, trae una carga grande de novedades y mejoras ha resultado relativamente problemático para algunos. Dos días después de instalarlo en todos los blogs de Hipertextual y con la experiencia de 16 blogs actualizados y una multitud de bloggers usándolo, recomiendo:

Sí actualizar:

  • Si tienes mucho tiempo para dedicar a resolver asuntos técnicos.
  • Si estás solo en tu blog o tus compañeros se adaptan a cambios con facilidad.
  • Si tienes versiones estándar de Apache, PHP, MySQL. No tendrás problema alguno de compatibilidad.
  • Si tienes pocos plugins.

No actualizar

  • Si funciones importantes de tu blog depende de plugins, algunos no están listos para la nueva versión.
  • Si hay muchos bloggers participando en el blog, es totalmente diferente y cuesta acostumbrarse a la nueva versión.
  • Tienes poco tiempo para dedicarle a la resolución de problemas técnicos.
  • Tienes instalado lighttpd 1.4, que por algún motivo bastante estúpido requiere lighttpd 1.5 que está en beta para algunas funciones importantes del blog. Grave error. No todos usamos Apache.

Una traducción al español ya está disponible y siempre nos queda el foro de discusión oficial para resolver dudas.